Welcome to AC Web.
Results 1 to 3 of 3
  1. #1

    Custom Spells Don't Work


    REGISTER! (FREE)
    Registered members see less ads
    and also gain access to other great features.
    Hello, I am using stoneharry's wow spell editor to copy/modify existing spells, but they don't work in-game. I've made changes to the spell in the editor, exported to DBC which I moved to my server's DBC folder, and also placed DBCs in custom patch-3.MPQ which was moved to WoW Data directory.

    Cleared WDB and restarted server but best I can make happen is I type .learn 33333 (custom spell ID) and nothing happens, doesn't appear in spellbook. But if I type .learn 33333 again it says You Already Know This Spell. If I .cast it with an enemy mob selected the mob dies after a brief moment, but no spell model or damage displayed, and nothing in combat log. (Modified shadow bolt volley). It seems like it wants to work but not really. Does anyone have experience in this? Help super appreciated, thank you.

    - - - Updated - - -

    Small update to anyone interested : Was able to get spells to show up in-game and be useable; had to modify the compression ruleset in my MPQ editor, apparently 1.12.1 WoW didn't like the default ruleset.

    Now have a new problem of the custom debuff I made casting but no debuff showing up on targeted enemy, just a casting animation and effect on my toon.

    Anyone familiar with this type of thing?

  2. #2


    Join Date
    Sep 2014
    Location
    René#6788 - I dont answer PMs
    Posts
    474
    The advice I can give is to copy an existing spell with similar functions (e.g. castable spell that adds a debuff, there's plenty) and then edit that spell until you get the hang of it.
    I personally only have experience in 335 and some in 434

  3. #3

    REGISTER! (FREE)
    Registered members see less ads
    and also gain access to other great features.
    Found that ruleset for compression of DBC files were not correct for vanilla WoW (1.12.1). Messed with some settings in Ladik's MPQ Editor and it's all working now. Also found out values in SQL database need to match up pretty closely with certain values in spell editor for things to work perfect.

    Thank you.

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •