Welcome to AC Web.
Results 1 to 15 of 28

Threaded View

  1. #1

    TrinityCore 3.3.5a - Hosting from Localhost

    Hello guys,

    Me and some friends want to try out a couple of things in 3.3.5a server (I host it), but they can't connect to my server (I created accounts to them).

    Heres what I tried so far:

    Opened ports:
    80 (Default port for Apache servers. If you aren't running a site of sorts, this is not required.)
    3306 (Default port for MySQL servers. If you don't need your MySQL to be accessible remotely, this is not required.)
    3443 (Default port for Remote Access, if you aren't using RA, this is not required.)
    7878 (Default port for Simple Object Access Protocol, if you aren't using SOAP, this is not required.)
    3724 (Mandatory realmlist port.)
    8085 (Mandatory World server port.)

    DNS server (no-ip.org)

    Hosts file have the followings:
    127.0.0.1 Dyndns
    (IPv4 Address) InternalIP Dyndns
    (Whatsismyip.com) ExternalIP Dnydns
    (Default Gateway) RouterIP Dyndns

    (without the (infos))
    I have a TP-link router, and I opened those ports with the (IPv4 Address) InternalIP.

    What I do wrong?

    I followed the following guides:
    http://www.ac-web.org/forums/showthr...-server-public
    https://www.aparat.com/v/dQGjf/How_t..._Server_Public
    https://www.mmopro.org/guides-and-tu...-realm-public-[easy-noob-tutorial-pictures]-*hot*.html
    https://www.ownedcore.com/forums/wor...asy-guide.html

    I using Windows10 Pro 64bit, and I opened the ports at my system aswell. Only I have windows firewall, but when they tried to connect, I disabled it, but no luck.

    Realm, Worldserver ports are opened, and they are the same at the auth_db and the configs.


    Additional note:
    If I add my external IP to the authserver.conf, I stuck at here:
    Using configuration file authserver.conf.
    OpenSSL 1.0.2s 28 May 2019 (Library: OpenSSL 1.0.2s 28 May 2019)
    Opening DatabasePool 'auth'. Asynchronous connections: 1, synchronous connections: 1.
    Its only start up, if I add the 127.0.0.1 IP to the config.

    Please someone help me out
    Last edited by levcsu; 09-08-2019 at 06:23 PM.

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •