Welcome to AC Web.
Page 1 of 2 12 LastLast
Results 1 to 15 of 28

Hybrid View

  1. #1

    TrinityCore 3.3.5a - Hosting from Localhost

    Hello guys,

    Me and some friends want to try out a couple of things in 3.3.5a server (I host it), but they can't connect to my server (I created accounts to them).

    Heres what I tried so far:

    Opened ports:
    80 (Default port for Apache servers. If you aren't running a site of sorts, this is not required.)
    3306 (Default port for MySQL servers. If you don't need your MySQL to be accessible remotely, this is not required.)
    3443 (Default port for Remote Access, if you aren't using RA, this is not required.)
    7878 (Default port for Simple Object Access Protocol, if you aren't using SOAP, this is not required.)
    3724 (Mandatory realmlist port.)
    8085 (Mandatory World server port.)

    DNS server (no-ip.org)

    Hosts file have the followings:
    127.0.0.1 Dyndns
    (IPv4 Address) InternalIP Dyndns
    (Whatsismyip.com) ExternalIP Dnydns
    (Default Gateway) RouterIP Dyndns

    (without the (infos))
    I have a TP-link router, and I opened those ports with the (IPv4 Address) InternalIP.

    What I do wrong?

    I followed the following guides:
    http://www.ac-web.org/forums/showthr...-server-public
    https://www.aparat.com/v/dQGjf/How_t..._Server_Public
    https://www.mmopro.org/guides-and-tu...-realm-public-[easy-noob-tutorial-pictures]-*hot*.html
    https://www.ownedcore.com/forums/wor...asy-guide.html

    I using Windows10 Pro 64bit, and I opened the ports at my system aswell. Only I have windows firewall, but when they tried to connect, I disabled it, but no luck.

    Realm, Worldserver ports are opened, and they are the same at the auth_db and the configs.


    Additional note:
    If I add my external IP to the authserver.conf, I stuck at here:
    Using configuration file authserver.conf.
    OpenSSL 1.0.2s 28 May 2019 (Library: OpenSSL 1.0.2s 28 May 2019)
    Opening DatabasePool 'auth'. Asynchronous connections: 1, synchronous connections: 1.
    Its only start up, if I add the 127.0.0.1 IP to the config.

    Please someone help me out
    Last edited by levcsu; 09-08-2019 at 06:23 PM.

  2. #2
    Got discord?

    Either you forwarded to the wrong IP address, the firewall are denying access or you don't have a public IP.

  3. #3
    Quote Originally Posted by Extremeloner View Post
    Got discord?

    Either you forwarded to the wrong IP address, the firewall are denying access or you don't have a public IP.
    My router IP (default gateway) is: 192.168.0.1
    IPv4 address: 192.168.0.103

    I tried to open the ports on the ....103, and tried with the ..0.1 aswell, but either of them worked. I don't know what to do :/

    - - - Updated - - -

    And no, I dont have discord

    - - - Updated - - -

    Additional note:
    If I add my external IP to the authserver.conf, I stuck at here:
    Using configuration file authserver.conf.
    OpenSSL 1.0.2s 28 May 2019 (Library: OpenSSL 1.0.2s 28 May 2019)
    Opening DatabasePool 'auth'. Asynchronous connections: 1, synchronous connections: 1.
    Its only start up, if I add the 127.0.0.1 IP to the config.

  4. #4
    Would just be easier if we did this over team viewer. The gateway doesn't matter you only have to concentrate on the ipv4 on the hosting machine.

    You should not change anything in the authserver.conf only in the table "realmlist" in your auth database. The row with column "address" must be changed to the IP provided from your isp "found on ipchicken.com" then no further configuration required for TrinityCore.

    For the port forwarding, if you're 100% positive 192.168.0.103 is the IP of your host machine and the firewall is disabled then you should be able to connect (unless you don't have a public ip those usually costs a small fee every month).

    You can see your computers IPv4 address by writing "ipconfig" in cmd.
    Last edited by Extremeloner; 09-08-2019 at 06:41 PM.

  5. #5
    Quote Originally Posted by Extremeloner View Post
    Would just be easier if we did this over team viewer. The gateway doesn't matter you only have to concentrate on the ipv4 on the hosting machine.

    You should not change anything in the authserver.conf only in the table "realmlist" in your auth database. The column "address" must be changed to the IP provided from your isp "found on ipchicken.com" then no further configuration required for TrinityCore.

    For the port forwarding, if you're 100% positive 192.168.0.103 is the IP of your host machine and the firewall is disabled then you should be able to connect (unless you don't have a public ip those usually costs a small fee every month).

    You can see your computers IPv4 address by writing "ipconfig" in cmd.
    cmd/ipconfig -all, theres my (Preferred) ip is the 192.168.0.103. That IP I used while I opened the ports. Thats why I don't know, why they unable to connect to my server. :/
    Maybe a tutorial to open ports/application trough WIndow Defender/Firewall could be help if you able to.

  6. #6
    Quote Originally Posted by levcsu View Post
    cmd/ipconfig -all, theres my (Preferred) ip is the 192.168.0.103. That IP I used while I opened the ports. Thats why I don't know, why they unable to connect to my server. :/
    Maybe a tutorial to open ports/application trough WIndow Defender/Firewall could be help if you able to.
    Since your firewall is disabled you don't need to make a new inbound rule, however my wildest guess is you do not have a public IP. I pay 3€/m extra for that.

    If you got a webserver on your machine, then try to forward port 80 and go to https://www.yougetsignal.com/tools/open-ports/ to see if it responds. If not then chances are you need to call your isp and get one.

    - - - Updated - - -

    If that doesn't seem to be the case, then I would like to see your config files, port forwards from your router and the row from your realmlist table.

  7. #7
    Remove all the changes you did to the hosts file. They are not needed and is the most likely source of this problem.

  8. #8
    Quote Originally Posted by MyLilSuccy View Post
    Remove all the changes you did to the hosts file. They are not needed and is the most likely source of this problem.
    So, change this:
    # localhost name resolution is handled within DNS itself.
    # 127.0.0.1 localhost
    # ::1 localhost

    127.0.0.1 dns
    192.168.0.103 dns
    externalIP dns
    192.168.0.1 dns
    to:
    # localhost name resolution is handled within DNS itself.
    # 127.0.0.1 localhost
    # ::1 localhost
    ????

  9. #9
    Quote Originally Posted by levcsu View Post
    So, change this:


    to:
    ????
    omg remove that. yes, yes.
    Last edited by Extremeloner; 09-08-2019 at 07:08 PM.

  10. #10
    Quote Originally Posted by Extremeloner View Post
    omg remove that. yes, yes.
    I removed those lines, and they say:
    Connecting (infinite loop). Nothing changed

    Realm table have the external ip address (direct IP not the no-ip.org dns), and still nothing new I hate this router

  11. #11
    Quote Originally Posted by levcsu View Post
    I removed those lines, and they say:
    Connecting (infinite loop). Nothing changed

    Realm table have the external ip address (direct IP not the no-ip.org dns), and still nothing new I hate this router
    I would like to see your config files, port forwards from your router and the row from your realmlist table.

  12. #12
    Well some routers need to be rebooted in order for the port forwards to take effect, so you might want to try that.

    Further, what are your realmlist.wtf settings. Is it connecting from the same machine as the server or are you using the external IP?

    With the server running, got to https://www.yougetsignal.com/tools/open-ports/ and check that the ports are open.

    Now check that a basic connection can be done by going to this website (https://www.adminkit.net/telnet.aspx) and see if you can make a telnet connection on port 3724. If it is successful, the status will say so and the text box will usually be blank. Otherwise you will get a failed message.

    Now do the same again but use the worldserver port (8085). If successful, the connection will say so and the text box will have some garbage characters in it (it is actually the server trying to talk back with the game client).

  13. #13
    Web Developer

    Join Date
    Oct 2010
    Location
    somewhere between <?php and ?>
    Posts
    3,020
    Try this
    Code:
    UPDATE auth.realmlist SET address = "YOURIPADDRESS", localAddress = "127.0.0.1", port=8085
    Run this query in your database. you can get your ipaddress from whatismyip.com you should NOT write your IPv4 Address or Default Gateway there. That is a very common mistake and another mistake that i have seen alot of people doing is that they write their address in the localAddress column aswell and this must be set to either 127.0.0.1 or localhost since its your localAddress. So this query will fix those issues

  14. #14
    Quote Originally Posted by Tok124 View Post
    Try this
    Code:
    UPDATE auth.realmlist SET address = "YOURIPADDRESS", localAddress = "127.0.0.1", port=8085
    Run this query in your database. you can get your ipaddress from whatismyip.com you should NOT write your IPv4 Address or Default Gateway there. That is a very common mistake and another mistake that i have seen alot of people doing is that they write their address in the localAddress column aswell and this must be set to either 127.0.0.1 or localhost since its your localAddress. So this query will fix those issues
    Thanks, but my realm table contains my externalIP (from whatismyip)

    - - - Updated - - -

    Quote Originally Posted by MyLilSuccy View Post
    Well some routers need to be rebooted in order for the port forwards to take effect, so you might want to try that.

    Further, what are your realmlist.wtf settings. Is it connecting from the same machine as the server or are you using the external IP?

    With the server running, got to https://www.yougetsignal.com/tools/open-ports/ and check that the ports are open.

    Now check that a basic connection can be done by going to this website (https://www.adminkit.net/telnet.aspx) and see if you can make a telnet connection on port 3724. If it is successful, the status will say so and the text box will usually be blank. Otherwise you will get a failed message.

    Now do the same again but use the worldserver port (8085). If successful, the connection will say so and the text box will have some garbage characters in it (it is actually the server trying to talk back with the game client).
    Thank you I will check this out this afternoon

  15. #15
    Sometimes is problem with firewall or any external program that can control traffic, try to disable anti-virus and try to disable firewall. Then try to connect.

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •